Back to overview
Downtime
CDN Outage
May 13, 2026 at 7:33pm UTC
Affected services
CDN
Resolved
May 13, 2026 at 9:09pm UTC
The issue has been resolved.
Affected services
Created
May 13, 2026 at 7:33pm UTC
Our CDN is currently experiencing issues due to an upstream outage. During this time, website assets may fail to load.
Affected services