Back to overview
Downtime
SnowCaptcha Outage
Oct 14 at 04:36pm UTC
Affected services
SnowCaptcha
Resolved
Oct 14 at 04:53pm UTC
This issue has been resolved.
Affected services
Updated
Oct 14 at 04:43pm UTC
We have identified the cause of the issue. A fix has been rolled out and we're monitoring the result.
Affected services
Created
Oct 14 at 04:36pm UTC
We are aware of an outage affecting SnowCaptcha and are investigating.
Affected services