Back to overview
Maintenance

SnowMail Maintenance

Mar 10 at 03:45pm UTC  –  Mar 10 at 04:58pm UTC
Affected services
SnowMail

Resolved
Mar 10 at 04:58pm UTC

The maintenance has concluded. For more information about the outbound email domain, refer to this help center article.

Created
Mar 10 at 03:45pm UTC

Maintenance will be carried out on SnowMail to change the outbound email domain. No downtime is expected, but emails may be delayed during this time.