Back to overview
Degraded

MailChannels Rejecting SnowMail Emails

Feb 05 at 04:00pm UTC
Affected services
SnowMail

Resolved
Feb 06 at 05:36pm UTC

This issue has been resolved.

Created
Feb 05 at 04:00pm UTC

We are aware that customers using MailChannels for inbound spam filtering may not receive contact form submission emails and we're working with them to resolve this issue.

To our knowledge, other spam filters and email service providers are unaffected by this issue.